We’re experiencing intermittent failures on some trade orders

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Feb 27, 2025 - 15:00 PST

Update

We are continuing to work on a fix for this issue.
Posted Feb 27, 2025 - 13:30 PST

Identified

If your trade failed, please re-submit your order again
Posted Feb 27, 2025 - 13:29 PST