Issue processing ETH transaction

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Apr 06, 2023 - 13:49 PDT

Investigating

We are currently investigating this issue.
Posted Apr 06, 2023 - 12:46 PDT
This incident affected: Digital Assets (Ethereum).