Trades not available in new UI

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 04:42 PDT

Investigating

Please switch back to the Classic UI for trade-related functionalities. You can do so by clicking on your Profile icon and selecting Switch to Classic View.
Posted Jun 19, 2026 - 03:02 PDT
This incident affected: Trade (BitGo Trust, BitGo Singapore, BitGo Europe).