Degraded performance (potential slowness) of staking actions, Wallet section

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 30, 2023 - 13:15 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 30, 2023 - 12:34 PDT

Update

We are continuing to investigate this issue.
Posted Jun 30, 2023 - 11:47 PDT

Investigating

We are aware of the issue on our platform for the staking services and wallet actions. Our engineering team is currently investigating the issue.
Posted Jun 30, 2023 - 09:58 PDT
This incident affected: Wallets.