delay in OPETH transactions

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 04:19 PDT

Investigating

delay in OPETH transactions
Posted Jul 14, 2025 - 04:15 PDT
This incident affected: Digital Assets (Optimism).