Partial Service Degradation affecting sign-ups

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 11:58 PST

Update

We are continuing to investigate this issue.
Posted Dec 11, 2025 - 08:12 PST

Investigating

We are currently investigating intermittent failures affecting sign-ups.
Posted Dec 11, 2025 - 08:11 PST
This incident affected: Platform.