Delay in Receiving Emails and Notifications

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted May 06, 2026 - 07:58 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 06, 2026 - 07:49 PDT

Investigating

We are currently experiencing delays in sending Bitgo emails and notifications, including IP verification emails and email notifications related to pending approvals and transactions.
Posted May 06, 2026 - 07:12 PDT
This incident affected: Platform.