Login Issues Affecting IP Verification

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted May 12, 2026 - 02:00 PDT

Investigating

We are currently investigating an issue affecting users required to complete IP address verification during login. Some users may be unable to access their accounts at this time. New user sign-ups and account verifications are also impacted by this issue.
Posted May 12, 2026 - 01:55 PDT
This incident affected: Platform.