Delays in acknowledging Solana deposits and withdrawals

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jul 03, 2023 - 08:32 PDT

Investigating

We are currently investigating this issue.
Posted Jul 03, 2023 - 07:41 PDT
This incident affected: Digital Assets (Solana).