Failure to initiate wires

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 02:46 PDT

Investigating

Inability to Initiate Wire Transfers from Go account, we are currently investigating this issue.
Posted Aug 29, 2025 - 02:09 PDT
This incident affected: Trade.