Issue with New User Sign-Ups
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 12:34 PDT
Investigating
We are currently experiencing an issue affecting new user sign-ups. Users attempting to register may encounter delays or may not be able to complete the sign-up process.

- New users may not be able to sign up at this time.
- Existing users are not affected by this issue.
Posted Oct 10, 2024 - 08:24 PDT
This incident affected: Platform.