Delay in processing Casper withdrawals and deposits

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 01:43 PDT

Identified

We have identified the cause of this issue and are working on a resolution
Posted Jul 03, 2025 - 01:09 PDT

Investigating

We are currently investigating this issue.
Posted Jul 03, 2025 - 00:20 PDT
This incident affected: Digital Assets (Casper).