Issues with submitting trade via UI
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Aug 30, 2023 - 14:45 PDT
Investigating
We are currently investigating intermittent issues submitting trade via app.bitgo.com (user interface), this is not affecting API users. Please contact support@bitgo.com for faster resolution.
Posted Aug 30, 2023 - 12:27 PDT
This incident affected: Trade.