Portfolio clients are unable to access account
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Aug 04, 2021 - 18:05 PDT
Identified
We have identified the issue and a fix is being implemented
Posted Aug 04, 2021 - 16:55 PDT
This incident affected: Portfolio & Tax.