Zetachain (ERC20) name transitioning to ZetaEVM
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 08:41 PDT
Investigating
ZetaChain (ERC20) is currently undergoing a name change to ZetaEVM on our platform. We recommend pausing any withdrawal and deposit activities during this period to prevent any potential issues. Rest assured, your funds remain safe and secure.
Posted Mar 12, 2024 - 17:07 PDT
This incident affected: Wallets.