Intermittent issues accessing BitGo platform - both API and UI access are affected
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 21:51 PST
Investigating
We are currently investigating this issue.
Posted Nov 13, 2023 - 21:13 PST
This incident affected: API and Platform.