Issue processing BCH transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 18:40 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 10, 2021 - 17:51 PST
Investigating
We are currently investigating this issue.
Posted Nov 10, 2021 - 16:56 PST
This incident affected: Digital Assets (Bitcoin Cash).