Issues with accessing trade platform

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 21:14 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2026 - 20:09 PDT

Update

We are continuing to investigate this issue.
Posted Jul 16, 2026 - 18:20 PDT

Investigating

GCP (Google Cloud Provider) outage and trading is down in MENA, Europe, and BitGo Trust. We are currently investigating.
Posted Jul 16, 2026 - 18:19 PDT
This incident affected: Trade API (BitGo Trust Trade API, BitGo Europe Trade API, BitGo MENA Trade API) and Trade (BitGo Trust, BitGo Europe, BitGo MENA).