Elevated error rate during transaction signing for multiple coins

Incident Report for BitGo

Resolved

We experienced a network degradation between 1:30am and 3:30am UTC, which impacted some client requests during that window.
Posted Jun 30, 2026 - 21:02 PDT

Update

We are investigating why there is an elevated failure rate for transaction signing
Posted Jun 30, 2026 - 20:28 PDT

Investigating

We are currently investigating this issue.
Posted Jun 30, 2026 - 20:19 PDT
This incident affected: API and Wallets.