BitGo platform delay in processing transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 21:47 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 06, 2021 - 21:08 PST
Investigating
We are currently investigating this issue.
Posted Jan 06, 2021 - 20:36 PST