General Performance Issue for UI and API access
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 21:25 PDT
Update
This incident has been resolved.
Posted Sep 18, 2023 - 21:24 PDT
Identified
You may experience intermediate slowness accessing our site and for API calls. Our team has identified the issue and is working on a fix
Posted Sep 18, 2023 - 19:19 PDT
This incident affected: API, Wallets, and Platform.