Delay in Processing OSMO Transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 05:21 PDT
Investigating
We are currently investigating this issue.
Posted Sep 19, 2024 - 03:45 PDT