BCH Send Issues
Incident Report for BitGo
Resolved
This incident has been resolved
Posted Dec 16, 2021 - 07:54 PST
Investigating
We are currently investigating the issue.
Posted Dec 16, 2021 - 04:56 PST
This incident affected: Digital Assets (Bitcoin Cash).