Degraded performance with Go Accounts

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 20:33 PST

Update

We are continuing to investigate this issue.
Posted Dec 10, 2025 - 18:54 PST

Investigating

Issue accessing go accounts/trading wallet and its functions
Posted Dec 10, 2025 - 18:53 PST