Completed
The scheduled maintenance has been completed.
Posted Apr 11, 2026 - 15:45 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 11, 2026 - 12:00 PDT
Scheduled
BitGo will be conducting a scheduled upgrade to its underlying network infrastructure on April 11, 2026, from 12:00 PT to 23:59 PT, as part of our ongoing efforts to improve platform stability and performance.
A focused maintenance window is planned between 12:00 PT and 13:00 PT. During this time, a brief service interruption of up to one hour is possible.
Trading services will be impacted during this 1 hour window:
* All trading activity via API and app.bitgo.com will be paused
* Open orders will be paused and will resume once focused maintenance is complete
* New orders cannot be submitted during focused maintenance period
Outside of this maintenance window, no impact is expected. All services will automatically resume following the maintenance window.
If you have any questions, please reach out to us at support@bitgo.com.
Posted Mar 25, 2026 - 16:08 PDT
This scheduled maintenance affected: API, Wallets, Platform, Settlement, Reporting, Staking, Stablecoins, Digital Assets (Bitcoin (V1), Bitcoin, Litecoin, Bitcoin Cash, Bitcoin SV, Ethereum, Dash, ZCash, Ripple, Stellar, Algorand, EOS, Tron, Bitcoin Gold, Hedera Hashgraph, Tezos, RSK, Celo, Ethereum Classic, Stacks, Avalanche C-chain, EOS Tokens, Polkadot, Solana, NEAR, Doge, Polygon, Cardano, Binance Coin (BNB), Injective, Telegram Open Network, Avalanche P-chain, Atom, SUI, Optimism, SEI, Arbitrum, TON, Casper, TAO, Aptos, Berachain, Flow, Canton, Monad), Trade API (BitGo Trust Trade API, BitGo Singapore Trade API, BitGo Europe Trade API), and Trade (BitGo Trust, BitGo Singapore, BitGo Europe).