Client balances from Trades settled on Dec 15th are not being reflected in the UI
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Dec 15, 2022 - 22:03 PST
Investigating
We are currently investigating this issue.
Posted Dec 15, 2022 - 17:53 PST
This incident affected: Trade.