Delay in processing Fiat Withdrawals on Platform
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 18:04 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 27, 2024 - 15:35 PST
Investigating
We are currently investigating this issue.
Posted Feb 27, 2024 - 13:51 PST
This incident affected: Platform.