Bitgo Go Accounts are experiencing an issue where the Deposit/Withdrawal buttons are disabled in the UI

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 15:04 PDT

Identified

We have identified the cause of this issue and are working on a resolution
Posted Jun 19, 2025 - 13:23 PDT
This incident affected: Wallets and Settlement.