Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Dec 06, 2025 - 07:12 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 06, 2025 - 07:11 PST
Scheduled
In order to keep improving our services, BitGo will be performing a scheduled maintenance on the infrastructure hosting our applications at https://app.bitgo.com. During this window, the application will be unavailable for 10 minutes and clients will experience an elevated error rate for 30 more minutes.
If you have any concerns about the availability of your account during this window, please reach out to our support team.
Posted Dec 06, 2025 - 07:10 PST
This scheduled maintenance affected: API, Wallets, Platform, Settlement, Portfolio & Tax, Reporting, Staking, Testnet, Trade API (BitGo Trust Trade API, BitGo Singapore Trade API, BitGo Europe Trade API), and Trade (BitGo Trust, BitGo Singapore, BitGo Europe).