Trade Order Statuses are not updating

Incident Report for BitGo

Resolved

Data Sync Issue has been resolved, and all Trade Statuses are up to date.
Posted Mar 24, 2025 - 15:43 PDT

Monitoring

Underlying issue has been resolved and all new trades are processing normally. The BitGo team is working to backfill Trade Execution details for Impacted Client Trades placed between 1:54pm PST and 2:22pm PST. No trade execution was impacted.
Posted Mar 24, 2025 - 15:27 PDT

Investigating

We are currently investigating this issue.
Posted Mar 24, 2025 - 14:20 PDT
This incident affected: Trade.