The Stellar network currently is in surge pricing mode, which may cause temporary delays in transactions. The delay can be in seconds upto few minutes in processing transactions.
Incident Report for BitGo
Resolved
Our nodes are currently stable, but you may see transactions lagging a bit while the network is on surge pricing. We're actively monitoring the situation but currently our nodes are processing all XLM transactions without any issue.
Posted Jun 17, 2022 - 11:23 PDT
Investigating
We are currently investigating this issue.
Posted Jun 16, 2022 - 08:24 PDT
This incident affected: API, Wallets and Digital Assets (Stellar).