Key creation errors for EdDSA coins (SOL, ALGO, XLM, NEAR, HBAR, ADA, etc.) - affecting self-managed cold wallets

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 12:48 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 24, 2025 - 12:09 PST

Investigating

We are investigating reports of key creation errors affecting EdDSA coins in Production. Clients are currently unable to create self managed cold EdDSA keys and may experience issues with withdrawals. Hot wallet key creation and transfers remain unaffected.
Posted Nov 24, 2025 - 11:24 PST
This incident affected: Platform.