DOT Custodial Withdrawals unable to be processed
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 07:06 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 02, 2023 - 19:13 PST
Update
We are continuing to investigate this issue.
Posted Feb 02, 2023 - 14:59 PST
Investigating
We are currently investigating this issue.
Posted Feb 02, 2023 - 14:59 PST