Issue with sending email notifications
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Feb 02, 2025 - 21:02 PST
Investigating
We are currently investigating this issue.
Posted Feb 02, 2025 - 18:43 PST
This incident affected: Platform.