XRP Services Non-Operational
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 15, 2020 - 21:20 PST
Investigating
We are currently investigating this issue.
Posted Nov 15, 2020 - 20:21 PST
This incident affected: Digital Assets (Ripple).