Issues with ETH staking

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 19:47 PDT

Update

Due to issues with our partners API, there is disruption to ETH staking. Users will be unable to provision. Bitgo and partners are working to restore staking service for ETH shortly
Posted Apr 03, 2025 - 19:33 PDT

Investigating

We are currently investigating this issue.
Posted Apr 03, 2025 - 17:54 PDT
This incident affected: Digital Assets (Ethereum) and Staking.