The TON network has been unresponsive for the past 45 minutes

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 01, 2025 - 07:20 PDT

Identified

Transactions and related services may not function during this time. This is a network-wide issue with TON and not an issue on BitGo's end.
Track status: https://tonscan.com/blocks
Posted Jun 01, 2025 - 06:13 PDT