Test Environment is experiencing issue
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 08:16 PST
Investigating
We are currently investigating the issue
Posted Nov 14, 2022 - 07:09 PST
This incident affected: API and Wallets.