zec is offline

Incident Report for BitGo

Resolved

This incident is resolved
Posted Nov 15, 2022 - 06:26 PST

Investigating

We are currently investigating the issue
Posted Nov 15, 2022 - 05:39 PST
This incident affected: API, Wallets and Digital Assets (ZCash).