Recent Settlement History Unavailable on 'Settle' Page"
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 15:17 PDT
Investigating
We are experiencing an issue where clients are unable to see their recent settlement history on "Settle" page. We are actively investigating the issue and will provide an update once resolved.
Posted Apr 11, 2024 - 14:40 PDT
This incident affected: Settlement.