XRP Mainnet Halt: Global Issue Impacting Transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Feb 04, 2025 - 16:37 PST
Investigating
The XRP mainnet is currently facing issues and has halted at block 93927173, preventing you from sending or receiving XRP.

This is a global issue affecting all users, not just BitGo.
Posted Feb 04, 2025 - 14:45 PST
This incident affected: Digital Assets (Ripple).