Fiat USD withdrawals from Trading Account are showing incorrect fee amount.
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted May 23, 2022 - 15:19 PDT
Investigating
Fiat USD withdrawals from Trading Account are showing incorrect fee amount.
Trades are not affected. Trading API is not affected.
Posted May 23, 2022 - 12:02 PDT
This incident affected: Trade.