Issues with Covering Open Margin Positions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 17:11 PST
Investigating
We are currently investigating this issue.
Posted Nov 20, 2024 - 14:30 PST
This incident affected: Trade.