Delays in processing incoming Avalanche transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Jul 07, 2023 - 16:20 PDT
Investigating
We are currently investigating this issue.
Posted Jul 07, 2023 - 07:04 PDT
This incident affected: Digital Assets (Avalanche C-chain).