Delay in processing deposit/withdrawals for LTC

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Apr 25, 2026 - 11:06 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 25, 2026 - 10:42 PDT

Investigating

We're currently experiencing network-wide issues affecting the LTC. As a result, transaction processing may be delayed. Our team is monitoring the situation and will provide updates as more information becomes available.
Posted Apr 25, 2026 - 07:04 PDT
This incident affected: Digital Assets (Litecoin).