Delay in processing email notifications

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Oct 24, 2024 - 04:54 PDT

Investigating

We are currently investigating this issue.
Posted Oct 24, 2024 - 03:21 PDT