Delay in processing INJ withdrawals and deposits

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 10:02 PDT

Update

This is a network wide chain-halt. Our team is monitoring the situation and will provide updates as more information becomes available.
Posted Apr 28, 2026 - 09:29 PDT

Investigating

We are currently investigating this issue.
Posted Apr 28, 2026 - 09:22 PDT
This incident affected: Staking and Digital Assets (Injective).