Delays in processing BTC transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted May 26, 2023 - 04:42 PDT
Update
Some bitcoin transactions are not being processed until they are confirmed in a block.
Posted May 25, 2023 - 18:01 PDT
Investigating
We are experiencing delays in updating the btc transactions status, you might also receive this error intermittently: transaction attempted to double spend.
Posted May 25, 2023 - 06:19 PDT
This incident affected: Digital Assets (Bitcoin).