Issue processing ETH and ERC20 transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 05:08 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 27, 2024 - 04:25 PDT
Investigating
We are currently encountering a delay in confirming ETH and ERC20 transactions to align with their on-chain status updates.
Posted Mar 27, 2024 - 00:51 PDT
This incident affected: Digital Assets (Ethereum).