Delayed Reporting - Recent activity may not appear in reports

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 17:39 PST

Update

We are continuing to investigate this issue.
Posted Feb 04, 2025 - 17:39 PST

Investigating

We are currently investigating this issue.
Posted Feb 04, 2025 - 13:58 PST
This incident affected: Reporting.